HDBaseT with HID USB Support?

HomeForumsWelcome to the Installer Zone Forum!HDBaseT with HID USB Support?

Tagged: , , ,

This topic contains 1 reply, has 2 voices, and was last updated by  Daniel Shwartzberg 6 days, 17 hours ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4395

    Apologies if this is not the right forum for this kind of question but I am really struggling to find a solution.

    I need to connect a touch display (ELO 2094L) which has a Amtel touch controller that is seen by Windows as a HID device, to a host machine using a single cable. I am really struggling to find a device that will do both video and USB2.0 (with HID support). Is there a protocol limitation here or is it just niche? The only units I have found are the Adder XD522 however this is really large and I am space constrained on the transmitter side (around 100x100x25mm / 4x4x1″).

    As an aside, I am also injecting POE using a MicroTik Passive POE injector to send 12V down the line however this seems to work fine in the tests I have done with a Digitus unit.

    Any help on brands I should look at or known issues/solutions around what I am trying to do would be greatly appreciated!

    #4396
    Daniel Shwartzberg
    HDBaseT Alliance

    Hi James,

    Many thanks for getting in touch – this is definitely the correct place to ask such questions!

    HDBaseT support for USB 2.0 was introduced with HDBaseT spec 2.0 and continues into spec 3.0. The good news is that USB HID extension (together with video extension) is supported by multiple vendors, including companies such as Aten and ProAV Edge. As always, we recommend you only choose equipment that appears in our Certified Product list (https://products.hdbaset.org/avcat/ctl18927/index.cfm). You can select “USB 2.0 Host” or “USB 2.0 Device” options in the “HDBaseT Specification” filter on the left side of the screen, and this will give you suitable products for your needs.

    Good luck!

    Daniel

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.